您現在的位置:程序化交易>> 期貨公式>> 文華財經>> 文華財經知識>>正文內容

老師,你好,,, [文華財經]

  • 咨詢內容: ?修改文化可用的DRAWICON(CURRBARSCOUNT=D-7 AND NOT(CURRBARSCOUNT=1),L,4);{波段高低點}G:=ZIG((H+MAX(C,O))/2,5);G1:=G>REF(G,1) AND G>REFX(G,1);D1:=G<REF(G,1) AND G<REFX(G,1);D:=ZIG((L+MIN(C,O))/2,5);G2:=D>REF(D,1) AND D>REFX(D,1);D2:=D<REF(D,1) AND D<REFX(D,1);GG:=FILTER(G1 OR G2,5) AND CURRBARSCOUNT>D;DD:=FILTER(D1 OR D2,5) AND CURRBARSCOUNT>D;{前期高低點距今}GB1:=BARSLAST(GG); ?????????GB2:=REFV(GB1,GB1+1)+GB1+1;GB3:=REFV(GB1,GB2+1)+GB2+1;GB4:=REFV(GB1,GB3+1)+GB3+1;DB1:=BARSLAST(DD); ?????????DB2:=REFV(DB1,DB1+1)+DB1+1;?DB3:=REFV(DB1,DB2+1)+DB2+1;?DB4:=REFV(DB1,DB3+1)+DB3+1;{均線}E2:=EMA(C,14);???????????????A21:=REFV(100*ABS(G-E2)/E2,GB1)<2; A22:=REFV(100*ABS(G-E2)/E2,GB2)<2;????????????????A23:=REFV(100*ABS(G-E2)/E2,GB3)<2; A24:=REFV(100*ABS(G-E2)/E2,GB4)<2;???????????????B21:=REFV(100*ABS(D-E2)/E2,DB1)<2; B22:=REFV(100*ABS(D-E2)/E2,DB2)<2;????????????????B23:=REFV(100*ABS(D-E2)/E2,DB3)<2; B24:=REFV(100*ABS(D-E2)/E2,DB4)<2;????????????????CX2:=A21+A22+A23+A24+B21+B22+B23+B24,NODRAW;?E3:=EMA(C,25);???????????????A31:=REFV(100*ABS(G-E3)/E3,GB1)<2; A32:=REFV(100*ABS(G-E3)/E3,GB2)<2;????????????????A33:=REFV(100*ABS(G-E3)/E3,GB3)<2; A34:=REFV(100*ABS(G-E3)/E3,GB4)<2;???????????????B31:=REFV(100*ABS(D-E3)/E3,DB1)<2; B32:=REFV(100*ABS(D-E3)/E3,DB2)<2;????????????????B33:=REFV(100*ABS(D-E3)/E3,DB3)<2; B34:=REFV(100*ABS(D-E3)/E3,DB4)<2;????????????????CX3:=A31+A32+A33+A34+B31+B32+B33+B34,NODRAW;E4:=EMA(C,99);???????????????A41:=REFV(100*ABS(G-E4)/E4,GB1)<2; A42:=REFV(100*ABS(G-E4)/E4,GB2)<2;????????????????A43:=REFV(100*ABS(G-E4)/E4,GB3)<2; A44:=REFV(100*ABS(G-E4)/E4,GB4)<2;???????????????B41:=REFV(100*ABS(D-E4)/E4,DB1)<2; B42:=REFV(100*ABS(D-E4)/E4,DB2)<2;????????????????B43:=REFV(100*ABS(D-E4)/E4,DB3)<2; B44:=REFV(100*ABS(D-E4)/E4,DB4)<2;????????????????CX4:=A41+A42+A43+A44+B41+B42+B43+B44,NODRAW;E5:=EMA(C,144);???????????????A51:=REFV(100*ABS(G-E5)/E5,GB1)<2; A52:=REFV(100*ABS(G-E5)/E5,GB2)<2;????????????????A53:=REFV(100*ABS(G-E5)/E5,GB3)<2; A54:=REFV(100*ABS(G-E5)/E5,GB4)<2;???????????????B51:=REFV(100*ABS(D-E5)/E5,DB1)<2; B52:=REFV(100*ABS(D-E5)/E5,DB2)<2;????????????????B53:=REFV(100*ABS(D-E5)/E5,DB3)<2; B54:=REFV(100*ABS(D-E5)/E5,DB4)<2;????????????????CX5:=A51+A52+A53+A54+B51+B52+B53+B54,NODRAW;E6:=EMA(C,321);???????????????A61:=REFV(100*ABS(G-E6)/E6,GB1)<2; A62:=REFV(100*ABS(G-E6)/E6,GB2)<2;????????????????A63:=REFV(100*ABS(G-E6)/E6,GB3)<2; A64:=REFV(100*ABS(G-E6)/E6,GB4)<2;???????????????B61:=REFV(100*ABS(D-E6)/E6,DB1)<2; B62:=REFV(100*ABS(D-E6)/E6,DB2)<2;????????????????B63:=REFV(100*ABS(D-E6)/E6,DB3)<2; B64:=REFV(100*ABS(D-E6)/E6,DB4)<2;???????????????CX6:=A61+A62+A63+A64+B61+B62+B63+B64,NODRAW;?E7:=EMA(C,453);???????????????A71:=REFV(100*ABS(G-E7)/E7,GB1)<2; A72:=REFV(100*ABS(G-E7)/E7,GB2)<2;????????????????A73:=REFV(100*ABS(G-E7)/E7,GB3)<2; A74:=REFV(100*ABS(G-E7)/E7,GB4)<2;???????????????B71:=REFV(100*ABS(D-E7)/E7,DB1)<2; B72:=REFV(100*ABS(D-E7)/E7,DB2)<2;????????????????B73:=REFV(100*ABS(D-E7)/E7,DB3)<2; B74:=REFV(100*ABS(D-E7)/E7,DB4)<2;????????????????CX7:=A71+A72+A73+A74+B71+B72+B73+B74,NODRAW;E8:=EMA(C,550);???????????????A81:=REFV(100*ABS(G-E8)/E8,GB1)<2; A82:=REFV(100*ABS(G-E8)/E8,GB2)<2;????????????????A83:=REFV(100*ABS(G-E8)/E8,GB3)<2; A84:=REFV(100*ABS(G-E8)/E8,GB4)<2;???????????????B81:=REFV(100*ABS(D-E8)/E8,DB1)<2; B82:=REFV(100*ABS(D-E8)/E8,DB2)<2;????????????????B83:=REFV(100*ABS(D-E8)/E8,DB3)<2; B84:=REFV(100*ABS(D-E8)/E8,DB4)<2;????????????????CX8:=A81+A82+A83+A84+B81+B82+B83+B84;E9:=EMA(C,610);???????????????A91:=REFV(100*ABS(G-E9)/E9,GB1)<2; A92:=REFV(100*ABS(G-E9)/E9,GB2)<2;????????????????A93:=REFV(100*ABS(G-E9)/E9,GB3)<2; A94:=REFV(100*ABS(G-E9)/E9,GB4)<2;???????????????B91:=REFV(100*ABS(D-E9)/E9,DB1)<2; B92:=REFV(100*ABS(D-E9)/E9,DB2)<2;????????????????B93:=REFV(100*ABS(D-E9)/E9,DB3)<2; B94:=REFV(100*ABS(D-E9)/E9,DB4)<2;???????????????CX9:=A91+A92+A93+A94+B91+B92+B93+B94;?E10:=EMA(C,730);???????????????A101:=REFV(100*ABS(G-E10)/E10,GB1)<2; A102:=REFV(100*ABS(G-E10)/E10,GB2)<2;????????????????A103:=REFV(100*ABS(G-E10)/E10,GB3)<2; A104:=REFV(100*ABS(G-E10)/E10,GB4)<2;???????????????B101:=REFV(100*ABS(D-E10)/E10,DB1)<2; B102:=REFV(100*ABS(D-E10)/E10,DB2)<2;????????????????B103:=REFV(100*ABS(D-E10)/E10,DB3)<2; B104:=REFV(100*ABS(D-E10)/E10,DB4)<2;????????????????CX10:=A101+A102+A103+A104+B101+B102+B103+B104;E11:=EMA(C,888);???????????????A111:=REFV(100*ABS(G-E11)/E11,GB1)<2; A112:=REFV(100*ABS(G-E11)/E11,GB2)<2;????????????????A113:=REFV(100*ABS(G-E11)/E11,GB3)<2; A114:=REFV(100*ABS(G-E11)/E11,GB4)<2;???????????????B111:=REFV(100*ABS(D-E11)/E11,DB1)<2; B112:=REFV(100*ABS(D-E11)/E11,DB2)<2;????????????????B113:=REFV(100*ABS(D-E11)/E11,DB3)<2; B114:=REFV(100*ABS(D-E11)/E11,DB4)<2;????????????????CX11:=A111+A112+A113+A114+B111+B112+B113+B114;E12:=EMA(C,888);???????????????A121:=REFV(100*ABS(G-E12)/E12,GB1)<2; A122:=REFV(100*ABS(G-E12)/E12,GB2)<2;????????????????A123:=REFV(100*ABS(G-E12)/E12,GB3)<2; A124:=REFV(100*ABS(G-E12)/E12,GB4)<2;???????????????B121:=REFV(100*ABS(D-E12)/E12,DB1)<2; B122:=REFV(100*ABS(D-E12)/E12,DB2)<2;????????????????B123:=REFV(100*ABS(D-E12)/E12,DB3)<2; B124:=REFV(100*ABS(D-E12)/E12,DB4)<2;????????????????CX12:=A121+A122+A123+A124+B121+B122+B123+B124;MCX:=MAX(CX2,MAX(CX3,MAX(CX4,MAX(CX5,MAX(CX6,MAX(CX7,MAX(CX8,MAX(CX9,MAX(CX10,MAX(CX11,CX12))))))))));P2:=CX2=MCX AND MCX>1; P3:=CX3=MCX AND MCX>1; P4:=CX4=MCX AND MCX>1; P5:=CX5=MCX AND MCX>1;P6:=CX6=MCX AND MCX>1;?P7:=CX7=MCX AND MCX>1; P8:=CX8=MCX AND MCX>1; P9:=CX9=MCX AND MCX>1; P10:=CX10=MCX AND MCX>1; P11:=CX11=MCX AND MCX>1; P12:=CX12=MCX AND MCX>1;N1:=CONST(IF((P2 AND P4) OR (P3 AND P2=0 AND P4=0),30,IF(P2 AND P3 AND P4=0,25,IF(P2=0 AND P3 AND P4,35,IF(P2 AND P3=0 AND P4=0,20,IF(P2=0 AND P3=0 AND P4,40,0)))))),NODRAW;N2:=CONST(IF((P5 AND P7) OR (P6 AND P5=0 AND P7=0),60,IF(P5 AND P6 AND P7=0,55,IF(P5=0 AND P6 AND P7,65,IF(P5 AND P6=0 AND P7=0,50,IF(P5=0 AND P6=0 AND P7,70,0)))))),NODRAW;N3:=CONST(IF((P8 AND P10) OR (P9 AND P8=0 AND P10=0),90,IF(P8 AND P9 AND P10=0,85,IF(P8=0 AND P9 AND P10,95,IF(P8 AND P9=0 AND P10=0,80,IF(P8=0 AND P9=0 AND P10,100,0)))))),NODRAW;N4:=CONST(IF(P11 AND P12,115,IF(P11 AND P12=0,110,IF(P11=0 AND P12,120,0)))),NODRAW;周期:IF(N4>0,N4,IF(N3>0,N3,IF(N2>0,N2,IF(N1>0,N1,IF(TOTALBARSCOUNT<55,13,55))))),NODRAW;NOTEXTEE1:IF(N1>0,EMA(C,N1),DRAWNULL),COLORLIBLUE;NOTEXTEE2:IF(N2>0 AND N1<=0,EMA(C,N2),DRAWNULL),COLORLIBLUE;NOTEXTEE3:IF(N3>0 AND N1<=0 AND N2<=0,EMA(C,N3),DRAWNULL),COLORLIBLUE;NOTEXTEE4:IF(N4>0,EMA(C,N4),DRAWNULL),COLORLIBLUE;NOTEXTEE0:=EMA(C,周期);NOTEXT01:IF(NOTEXTEE0>=REF(NOTEXTEE0,1) AND 周期>1,NOTEXTEE0,DRAWNULL),COLORRED,LINETHICK2;NOTEXT02:IF(NOTEXTEE0<=REF(NOTEXTEE0,1) AND 周期>1,NOTEXTEE0,DRAWNULL),COLORGREEN,LINETHICK2;DRAWNUMBER(ISLASTBAR,EMA(C,周期),EMA(C,周期));DRAWKLINE(H,O,L,C);

    ?

    ?來源:程序化99

  • 文華技術人員: ? 參考
    CURRBARSCOUNT:=REFX1(BARPOS,100000)-BARPOS+1;DRAWICON(CURRBARSCOUNT=8-7 AND NOT(CURRBARSCOUNT=1),L,4);
    G:=ZIGZAG((H+MAX(C,O))/2,5,1);G1:=G>REF(G,1) AND G>REFX(G,1);D1:=G<REF(G,1) AND G<REFX(G,1);D:=ZIGZAG((L+MIN(C,O))/2,5,1);G2:=D>REF(D,1) AND D>REFX(D,1);D2:=D<REF(D,1) AND D<REFX(D,1);GG:=FILTER(G1 OR G2,5) AND CURRBARSCOUNT>D;DD:=FILTER(D1 OR D2,5) AND CURRBARSCOUNT>D;{前期高低點距今}GB1:=BARSLAST(GG);? ? ? ? ??GB2:=REF(GB1,GB1+1)+GB1+1;GB3:=REF(GB1,GB2+1)+GB2+1;GB4:=REF(GB1,GB3+1)+GB3+1;DB1:=BARSLAST(DD);? ? ? ? ??DB2:=REF(DB1,DB1+1)+DB1+1;?DB3:=REF(DB1,DB2+1)+DB2+1;?DB4:=REF(DB1,DB3+1)+DB3+1;{均線}E2:=EMA(C,20);? ? ? ? ? ? ? ?A21:=REF(100*ABS(G-E2)/E2,GB1)<2;?A22:=REF(100*ABS(G-E2)/E2,GB2)<2;?? ? ? ? ? ? ? ?A23:=REF(100*ABS(G-E2)/E2,GB3)<2;?A24:=REF(100*ABS(G-E2)/E2,GB4)<2;? ? ? ? ? ? ? ?B21:=REF(100*ABS(D-E2)/E2,DB1)<2;?B22:=REF(100*ABS(D-E2)/E2,DB2)<2;?? ? ? ? ? ? ? ?B23:=REF(100*ABS(D-E2)/E2,DB3)<2;?B24:=REF(100*ABS(D-E2)/E2,DB4)<2;?? ? ? ? ? ? ? ?CX2:=A21+A22+A23+A24+B21+B22+B23+B24,NODRAW;?E3:=EMA(C,30);? ? ? ? ? ? ? ?A31:=REF(100*ABS(G-E3)/E3,GB1)<2;?A32:=REF(100*ABS(G-E3)/E3,GB2)<2;?? ? ? ? ? ? ? ?A33:=REF(100*ABS(G-E3)/E3,GB3)<2;?A34:=REF(100*ABS(G-E3)/E3,GB4)<2;? ? ? ? ? ? ? ?B31:=REF(100*ABS(D-E3)/E3,DB1)<2;?B32:=REF(100*ABS(D-E3)/E3,DB2)<2;?? ? ? ? ? ? ? ?B33:=REF(100*ABS(D-E3)/E3,DB3)<2;?B34:=REF(100*ABS(D-E3)/E3,DB4)<2;?? ? ? ? ? ? ? ?CX3:=A31+A32+A33+A34+B31+B32+B33+B34,NODRAW;E4:=EMA(C,40);? ? ? ? ? ? ? ?A41:=REF(100*ABS(G-E4)/E4,GB1)<2;?A42:=REF(100*ABS(G-E4)/E4,GB2)<2;?? ? ? ? ? ? ? ?A43:=REF(100*ABS(G-E4)/E4,GB3)<2;?A44:=REF(100*ABS(G-E4)/E4,GB4)<2;? ? ? ? ? ? ? ?B41:=REF(100*ABS(D-E4)/E4,DB1)<2;?B42:=REF(100*ABS(D-E4)/E4,DB2)<2;?? ? ? ? ? ? ? ?B43:=REF(100*ABS(D-E4)/E4,DB3)<2;?B44:=REF(100*ABS(D-E4)/E4,DB4)<2;?? ? ? ? ? ? ? ?CX4:=A41+A42+A43+A44+B41+B42+B43+B44,NODRAW;E5:=EMA(C,50);? ? ? ? ? ? ? ?A51:=REF(100*ABS(G-E5)/E5,GB1)<2;?A52:=REF(100*ABS(G-E5)/E5,GB2)<2;?? ? ? ? ? ? ? ?A53:=REF(100*ABS(G-E5)/E5,GB3)<2;?A54:=REF(100*ABS(G-E5)/E5,GB4)<2;? ? ? ? ? ? ? ?B51:=REF(100*ABS(D-E5)/E5,DB1)<2;?B52:=REF(100*ABS(D-E5)/E5,DB2)<2;?? ? ? ? ? ? ? ?B53:=REF(100*ABS(D-E5)/E5,DB3)<2;?B54:=REF(100*ABS(D-E5)/E5,DB4)<2;?? ? ? ? ? ? ? ?CX5:=A51+A52+A53+A54+B51+B52+B53+B54,NODRAW;E6:=EMA(C,60);? ? ? ? ? ? ? ?A61:=REF(100*ABS(G-E6)/E6,GB1)<2;?A62:=REF(100*ABS(G-E6)/E6,GB2)<2;?? ? ? ? ? ? ? ?A63:=REF(100*ABS(G-E6)/E6,GB3)<2;?A64:=REF(100*ABS(G-E6)/E6,GB4)<2;? ? ? ? ? ? ? ?B61:=REF(100*ABS(D-E6)/E6,DB1)<2;?B62:=REF(100*ABS(D-E6)/E6,DB2)<2;?? ? ? ? ? ? ? ?B63:=REF(100*ABS(D-E6)/E6,DB3)<2;?B64:=REF(100*ABS(D-E6)/E6,DB4)<2;? ? ? ? ? ? ? ?CX6:=A61+A62+A63+A64+B61+B62+B63+B64,NODRAW;?E7:=EMA(C,70);? ? ? ? ? ? ? ?A71:=REF(100*ABS(G-E7)/E7,GB1)<2;?A72:=REF(100*ABS(G-E7)/E7,GB2)<2;?? ? ? ? ? ? ? ?A73:=REF(100*ABS(G-E7)/E7,GB3)<2;?A74:=REF(100*ABS(G-E7)/E7,GB4)<2;? ? ? ? ? ? ? ?B71:=REF(100*ABS(D-E7)/E7,DB1)<2;?B72:=REF(100*ABS(D-E7)/E7,DB2)<2;?? ? ? ? ? ? ? ?B73:=REF(100*ABS(D-E7)/E7,DB3)<2;?B74:=REF(100*ABS(D-E7)/E7,DB4)<2;?? ? ? ? ? ? ? ?CX7:=A71+A72+A73+A74+B71+B72+B73+B74,NODRAW;E8:=EMA(C,80);? ? ? ? ? ? ? ?A81:=REF(100*ABS(G-E8)/E8,GB1)<2;?A82:=REF(100*ABS(G-E8)/E8,GB2)<2;?? ? ? ? ? ? ? ?A83:=REF(100*ABS(G-E8)/E8,GB3)<2;?A84:=REF(100*ABS(G-E8)/E8,GB4)<2;? ? ? ? ? ? ? ?B81:=REF(100*ABS(D-E8)/E8,DB1)<2;?B82:=REF(100*ABS(D-E8)/E8,DB2)<2;?? ? ? ? ? ? ? ?B83:=REF(100*ABS(D-E8)/E8,DB3)<2;?B84:=REF(100*ABS(D-E8)/E8,DB4)<2;?? ? ? ? ? ? ? ?CX8:=A81+A82+A83+A84+B81+B82+B83+B84;E9:=EMA(C,90);? ? ? ? ? ? ? ?A91:=REF(100*ABS(G-E9)/E9,GB1)<2;?A92:=REF(100*ABS(G-E9)/E9,GB2)<2;?? ? ? ? ? ? ? ?A93:=REF(100*ABS(G-E9)/E9,GB3)<2;?A94:=REF(100*ABS(G-E9)/E9,GB4)<2;? ? ? ? ? ? ? ?B91:=REF(100*ABS(D-E9)/E9,DB1)<2;?B92:=REF(100*ABS(D-E9)/E9,DB2)<2;?? ? ? ? ? ? ? ?B93:=REF(100*ABS(D-E9)/E9,DB3)<2;?B94:=REF(100*ABS(D-E9)/E9,DB4)<2;? ? ? ? ? ? ? ?CX9:=A91+A92+A93+A94+B91+B92+B93+B94;?E10:=EMA(C,100);? ? ? ? ? ? ? ?A101:=REF(100*ABS(G-E10)/E10,GB1)<2;?A102:=REF(100*ABS(G-E10)/E10,GB2)<2;?? ? ? ? ? ? ? ?A103:=REF(100*ABS(G-E10)/E10,GB3)<2;?A104:=REF(100*ABS(G-E10)/E10,GB4)<2;? ? ? ? ? ? ? ?B101:=REF(100*ABS(D-E10)/E10,DB1)<2;?B102:=REF(100*ABS(D-E10)/E10,DB2)<2;?? ? ? ? ? ? ? ?B103:=REF(100*ABS(D-E10)/E10,DB3)<2;?B104:=REF(100*ABS(D-E10)/E10,DB4)<2;?? ? ? ? ? ? ? ?CX10:=A101+A102+A103+A104+B101+B102+B103+B104;E11:=EMA(C,110);? ? ? ? ? ? ? ?A111:=REF(100*ABS(G-E11)/E11,GB1)<2;?A112:=REF(100*ABS(G-E11)/E11,GB2)<2;?? ? ? ? ? ? ? ?A113:=REF(100*ABS(G-E11)/E11,GB3)<2;?A114:=REF(100*ABS(G-E11)/E11,GB4)<2;? ? ? ? ? ? ? ?B111:=REF(100*ABS(D-E11)/E11,DB1)<2;?B112:=REF(100*ABS(D-E11)/E11,DB2)<2;?? ? ? ? ? ? ? ?B113:=REF(100*ABS(D-E11)/E11,DB3)<2;?B114:=REF(100*ABS(D-E11)/E11,DB4)<2;?? ? ? ? ? ? ? ?CX11:=A111+A112+A113+A114+B111+B112+B113+B114;E12:=EMA(C,120);? ? ? ? ? ? ? ?A121:=REF(100*ABS(G-E12)/E12,GB1)<2;?A122:=REF(100*ABS(G-E12)/E12,GB2)<2;?? ? ? ? ? ? ? ?A123:=REF(100*ABS(G-E12)/E12,GB3)<2;?A124:=REF(100*ABS(G-E12)/E12,GB4)<2;? ? ? ? ? ? ? ?B121:=REF(100*ABS(D-E12)/E12,DB1)<2;?B122:=REF(100*ABS(D-E12)/E12,DB2)<2;?? ? ? ? ? ? ? ?B123:=REF(100*ABS(D-E12)/E12,DB3)<2;?B124:=REF(100*ABS(D-E12)/E12,DB4)<2;?? ? ? ? ? ? ? ?CX12:=A121+A122+A123+A124+B121+B122+B123+B124;MCX:=MAX(CX2,MAX(CX3,MAX(CX4,MAX(CX5,MAX(CX6,MAX(CX7,MAX(CX8,MAX(CX9,MAX(CX10,MAX(CX11,CX12))))))))));P2:=CX2=MCX AND MCX>1;?P3:=CX3=MCX AND MCX>1;?P4:=CX4=MCX AND MCX>1;?P5:=CX5=MCX AND MCX>1;P6:=CX6=MCX AND MCX>1;?P7:=CX7=MCX AND MCX>1;?P8:=CX8=MCX AND MCX>1;?P9:=CX9=MCX AND MCX>1;?P10:=CX10=MCX AND MCX>1;?P11:=CX11=MCX AND MCX>1;?P12:=CX12=MCX AND MCX>1;N1:=REFX1(IF((P2 AND P4) OR (P3 AND P2=0 AND P4=0),30,IF(P2 AND P3 AND P4=0,25,IF(P2=0 AND P3 AND P4,35,IF(P2 AND P3=0 AND P4=0,20,IF(P2=0 AND P3=0 AND P4,40,0))))),10000),NODRAW;N2:=REFX1(IF((P5 AND P7) OR (P6 AND P5=0 AND P7=0),60,IF(P5 AND P6 AND P7=0,55,IF(P5=0 AND P6 AND P7,65,IF(P5 AND P6=0 AND P7=0,50,IF(P5=0 AND P6=0 AND P7,70,0))))),10000),NODRAW;N3:=REFX1(IF((P8 AND P10) OR (P9 AND P8=0 AND P10=0),90,IF(P8 AND P9 AND P10=0,85,IF(P8=0 AND P9 AND P10,95,IF(P8 AND P9=0 AND P10=0,80,IF(P8=0 AND P9=0 AND P10,100,0))))),10000),NODRAW;N4:=REFX1(IF(P11 AND P12,115,IF(P11 AND P12=0,110,IF(P11=0 AND P12,120,0))),10000),NODRAW;周期:IF(N4>0,N4,IF(N3>0,N3,IF(N2>0,N2,IF(N1>0,N1,IF(REFX1(BARPOS,100000)<55,13,55))))),NODRAW;NOTEXTEE1:IF(N1>0,EMA(C,N1),NULL),COLORBLUE;NOTEXTEE2:IF(N2>0 AND N1<=0,EMA(C,N2),NULL),COLORBLUE;NOTEXTEE3:IF(N3>0 AND N1<=0 AND N2<=0,EMA(C,N3),NULL),COLORBLUE;NOTEXTEE4:IF(N4>0,EMA(C,N4),NULL),COLORBLUE;NOTEXTEE0:=EMA(C,周期);NOTEXT01:IF(NOTEXTEE0>=REF(NOTEXTEE0,1) AND 周期>1,NOTEXTEE0,NULL),COLORRED,LINETHICK2;NOTEXT02:IF(NOTEXTEE0<=REF(NOTEXTEE0,1) AND 周期>1,NOTEXTEE0,NULL),COLORGREEN,LINETHICK2;DRAWNUMBER1(ISLASTBAR,EMA(C,周期),EMA(C,周期),2);DRAWKLINE1(H,O,L,C);

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,謝謝您!)

怎么收費,代編流程等詳情請點擊閱讀,或QQ微信聯系我們!


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
双色球机选新浪彩票