您現在的位置:程序化交易>> 期貨公式>> 文華財經>> 文華財經知識>>正文內容

老師幫忙改 謝謝 [文華財經]

  • 咨詢內容: MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50;
    G1:=IF(-MMS>95,0,20);UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0
    AND G1)+1);
    KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 -
    100));
    KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);
    趨勢線:=EMA(((KS
    / 10) + EMA(CLOSE,10)),3);AA:=-100*(趨勢線-CLOSE)/趨勢線;
    AC:=(EMA(AA,5)
    );SSL:=EMA(CLOSE,3);MMV:=EMA(((SLOPE(CLOSE,22) * 20) +
    CLOSE),55);
    MM:=MA(MMV,1);STICKLINE(((SSL>MM)),SSL,MM,0.01,0),colorred;
    SA:=(MM*0.985);SS:=(MA(CLOSE,5));DD:=(MA(CLOSE,13));GG:=(MA(CLOSE,21));
    撈錢手:IF(((SSL>MM)),MM,SA),LINETHICK2,COLORFF00FF;
    能量線:=DMA(((CLOSE
    + OPEN) / 2),(VOL / (SMA(VOL,4,1)
    *4)));上開:=O;上收:=C;
    上高:=H;上低:=L;JJ:=(上開+上高+上低)/3;A:=EMA(JJ,4);智能黃金線:A,coloryellow,LINETHICK1;
    B:=REF(A,1);STICKLINE(((SSL<MM)),撈錢手,智能黃金線,0.01,0),COLORFFFF00;
    VA1:=EMA(上收,8);VA2:=EMA(上收,20);
    DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'★絕佳')
    ,LINETHICK2,colorred;
    DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.02,'★賣');
    DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND
    智能黃金線>REF(智能黃金線,1),VA1*0.97,'★買'),COLOR00FF00;
    選手A:=MA(上收,3);箱頂A:=MA(REF(HHV(上收,6),1),3);
    箱底A:=MA(REF(LLV(上收,3),1),3);T1:=MA(上收,20)>=REF(MA(上收,20),1);
    T2:=CROSS(選手A,箱底A)
    AND 箱頂A/箱底A>100/100 AND T1;
    T3:=CROSS(箱頂A,選手A) AND
    箱頂A/箱底A>100/100;
    選手:=MA(上收,2);箱頂:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2;
    箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2;
    T4:=CROSS(選手,箱底)
    AND 箱頂/箱底>110/100;
    T5:=CROSS(箱頂,選手) AND
    箱頂/箱底>110/100;
    VAR1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100;
    VAR2:=SMA(VAR1,3,1);VAR3:=SMA(VAR2,3,1);VAR4:=SMA(VAR3,3,1);
    DRAWTEXT(CROSS(VAR3,VAR4)AND(C>=O)AND
    VAR3<40 AND
    UOO>0,LOW*0.96,'★'),COLORF00FF0;
    STICKLINE(C>=O,C,O,3,0),colorred;STICKLINE(C>=O,H,L,0,0),coloryellow;
    STICKLINE(C<=O,C,O,3,0),colorgreen;STICKLINE(C<=O,H,L,0,0),COLORFFFF00;
    買線:=EMA(C,2);賣線:=EMA(SLOPE(C,21)*20+C,42);
    DRAWTEXT(CROSS(買線,賣線)AND
    箱頂>=REF(箱頂,1),LOW*0.95,'★跟'),COLOR00FFFF;
    STICKLINE(CROSS(買線,賣線),OPEN,CLOSE,3,0),COLOR00FFFF;

    ?

    ?來源:程序化99

  • 文華技術人員: 修改參考
    MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50; G1:=IF(-1*MMS>95,0,20); UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 AND G1)+1); KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100)); KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100); 趨勢線:=EMA(((KS / 10) + EMA(CLOSE,10)),3); AA:=-100*(趨勢線-CLOSE)/趨勢線; AC:=(EMA(AA,5) ); SSL:=EMA(CLOSE,3); MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55); MM:=MA(MMV,1); STICKLINE(((SSL>MM)),SSL,MM,0.01,0),COLORRED; SA:=(MM*0.985); SS:=(MA(CLOSE,5)); DD:=(MA(CLOSE,13)); GG:=(MA(CLOSE,21)); 撈錢手:IF(((SSL>MM)),MM,SA),LINETHICK2,COLORFF00FF; 能量線:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) *4))); 上開:=O; 上收:=C; 上高:=H; 上低:=L; JJ:=(上開+上高+上低)/3; A:=EMA(JJ,4); 智能黃金線:A,COLORYELLOW,LINETHICK1; B:=REF(A,1); STICKLINE(((SSL<MM)),撈錢手,智能黃金線,0.01,0),COLORFFFF00; VA1:=EMA(上收,8); VA2:=EMA(上收,20); DRAWTEXT(CROSS(ZIGZAG(C,8,1),REF(ZIGZAG(C,8,1),1)),LOW*0.978,'絕佳',LINETHICK2,COLORRED; DRAWTEXT(CROSS(REF(ZIGZAG(C,10,1),1),ZIGZAG(C,10,1)),HIGH*1.02,'賣'; DRAWTEXT(CROSS(VA1,VA2) AND (C>=O) AND 智能黃金線>REF(智能黃金線,1),VA1*0.97,'買',COLOR00FF00; 選手A:=MA(上收,3); 箱頂A:=MA(REF(HHV(上收,6),1),3); 箱底A:=MA(REF(LLV(上收,3),1),3); T1:=MA(上收,20)>=REF(MA(上收,20),1); T2:=CROSS(選手A,箱底A) AND 箱頂A/箱底A>100/100 AND T1; T3:=CROSS(箱頂A,選手A) AND 箱頂A/箱底A>100/100; 選手:=MA(上收,2); 箱頂:MA(REF(HHV(上收,30),1),2),COLOR0000FF,LINETHICK2; 箱底:MA(REF(LLV(上收,30),1),2),COLOR00FF00,LINETHICK2; T4:=CROSS(選手,箱底) AND 箱頂/箱底>110/100; T5:=CROSS(箱頂,選手) AND 箱頂/箱底>110/100; VAR1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100; VAR2:=SMA(VAR1,3,1); VAR3:=SMA(VAR2,3,1); VAR4:=SMA(VAR3,3,1); DRAWTEXT(CROSS(VAR3,VAR4) AND (C>=O) AND VAR3<40 AND UOO>0,LOW*0.96,'',COLORF00FF0; STICKLINE(C>=O,C,O,3,0),COLORRED; STICKLINE(C>=O,H,L,0,0),COLORYELLOW; STICKLINE(C<=O,C,O,3,0),COLORGREEN; STICKLINE(C<=O,H,L,0,0),COLORFFFF00; 買線:=EMA(C,2); 賣線:=EMA(SLOPE(C,21)*20+C,42); DRAWTEXT(CROSS(買線,賣線) AND 箱頂>=REF(箱頂,1),LOW*0.95,'跟',COLOR00FFFF; STICKLINE(CROSS(買線,賣線),OPEN,CLOSE,3,0),COLOR00FFFF;

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,謝謝您!)

怎么收費,代編流程等詳情請點擊閱讀,或QQ微信聯系我們!


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
双色球机选新浪彩票