您現在的位置:程序化交易>> 期貨公式>> 金字塔等>> 金字塔知識>>正文內容

老師,能幫忙移植個文華模型嗎 [金字塔]

  • 咨詢內容: 之前一直用文華進行交易,但是不是很好用,能幫忙移植到金字塔進行交易嗎? MID:=MA(C,N);//計算中軌? ? ? ? TMP:=STD(C,M)*SDEV;//計算標準差 DISPTOP:REF(MID,P)+TMP;//平移BOLL通道上軌 DISPBOTTOM:REF(MID,P)-TMP;//平移BOLL通道下軌 //系統入場 C>=DISPTOP,BPK; C<=DISPBOTTOM,SPK; C<0.97*BKPRICE,SP; C>1.03*SKPRICE,BP; AUTOFILTER; TRADE_OTHER('AUTO');

    ?

  • 金字塔客服:

    MID:=MA(C,N);//計算中軌??????
    TMP:=STD(C,M)*SDEV;//計算標準差
    DISPTOP:REF(MID,P)+TMP;//平移BOLL通道上軌
    DISPBOTTOM:REF(MID,P)-TMP;//平移BOLL通道下軌
    //系統入場


    if C>=DISPTOP then begin
    ?sellshort(HOLDING<0,1,MARKET);
    ?buy(HOLDING=0,1,MARKET);
    end

    if C>=DISPTOP then begin
    ?sell(HOLDING>0,1,MARKET);
    ?buyshort(HOLDING=0,1,MARKET);
    end

    if C<0.97*BKPRICE then begin
    ?sell(HOLDING>0,1,MARKET);
    end


    if C>1.03*SKPRICE then begin
    ?sellshort(HOLDING<0,1,MARKET);
    end

    ?

    ?來源:程序化久久網( www.tzcple.tw )

  • 用戶回復: 老師,提示這個東西,請問如何修改啊
    此主題相關圖片如下:qq圖片20190605205212.png

    ?

  • 網友回復:

    MID:=MA(C,N);//計算中軌??????
    TMP:=STD(C,M)*SDEV;//計算標準差
    DISPTOP:REF(MID,P)+TMP;//平移BOLL通道上軌
    DISPBOTTOM:REF(MID,P)-TMP;//平移BOLL通道下軌
    //系統入場


    if C>=DISPTOP then begin
    ?sellshort(HOLDING<0,1,MARKET);
    ?buy(HOLDING=0,1,MARKET);
    end

    if C>=DISPTOP then begin
    ?sell(HOLDING>0,1,MARKET);
    ?buyshort(HOLDING=0,1,MARKET);
    end

    if C<0.97*ENTERPRICE? and HOLDING>0 then begin
    ?sell(1,1,MARKET);
    end


    if C>1.03*ENTERPRICE and HOLDING<0 then begin
    ?sellshort(1,1,MARKET);
    end

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,謝謝您!)

怎么收費,代編流程等詳情請點擊閱讀,或QQ微信聯系我們!


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
双色球机选新浪彩票