您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

換手明細指標公式[其他軟件公式]

相關標簽:分時量比源碼指標公式 、 量比指標短線實用 、 量比指標代碼 、 神奇的量比指標公式 、 量比選股指標公式 、 漲跌周期指標公式代碼 、 布林線指標公式代碼 、 量比和換手率指標公式 、 通達信量比指標公式 、 macd指標公式代碼 、 經傳軟件指標公式代碼 、 量比指標公式源碼 、

?

別看這個指標 大眾化,
老頭但集結多家之精華,從源碼中能看到 游子和金蘭二位老師的影子。

簡潔,詳細,常用。
使用中 要考慮區分 超級大盤股 的換手
二日換手:2天換手之和;
三日換手:3天換手之和;
五日換手:5天換手之和;

十日換手:10天換手之和。
大智慧新一代源碼

?

?

原理解析:


?

?來源:程序化99( www.tzcple.tw )

源碼:

?

?


{換手明細}
歷史量比:VOL/MA(VOL,5);
換手:(VOL*100/CAPITAL),STICK;
二日換手:SUM(換手,2);
三日換手:SUM(換手,3);
五日換手:SUM(換手,5);
十日換手:SUM(換手,10);
STICKLINE(換手<=1,0,VOL,6,0),COLORWHITE;
STICKLINE(換手>1 AND 換手<=3 ,0,VOL,6,0),color00FF00;
STICKLINE(換手>3 AND 換手<=5 ,0,VOL,6,0),colorf0f000;
STICKLINE(換手>5 AND 換手<=8 ,0,VOL,6,0),COLOR8788F6;
STICKLINE(換手>8 AND 換手<=10 ,0,VOL,6,0),coloryellow;
STICKLINE(換手>10 AND 換手<=15 ,0,VOL,6,0),COLORff00ff;
STICKLINE(換手>15 ,0,VOL,6,0),COLORRED;
DRAWTEXTREL(1,20,'當日巨大換手股價且在高位,主力出貨。低位多日充分換手,主力要拉升'),COLORRED;
DRAWTEXTREL(1,110,'換手小于1%■■白色柱地量'),COLORWHITE;
DRAWTEXTREL(1,200,'換手1-3% ■■新綠柱低靡'),color00FF00;
DRAWTEXTREL(1,290,'換手3-5% ■■淡蘭柱溫和'),colorf0f000;
DRAWTEXTREL(230,110,'換手5-8% ■■淡黃柱活躍'),COLOR8788F6;
DRAWTEXTREL(230,200,'換手8-10%■■黃柱高度活躍'),coloryellow;
DRAWTEXTREL(450,110,'換手10-15% ■■玖紅柱放量'),COLORff00ff;
DRAWTEXTREL(450,200,'換手大于15%■■大紅柱巨量'),COLORRED;
主力1:=IF(換手>10,V*0.9,V*0.1);
主力2:=IF(BETWEEN(換手,8,10),V*0.8,V*0.2);
主力3:=IF(BETWEEN(換手,5,8),V*0.6,V*0.4);
主力動向:(主力1+主力2+主力3)/3,colorred,LINETHICK0;
散戶1:=IF(BETWEEN(換手,5,3),V*0.6,V*0.4);
散戶2:=IF(BETWEEN(換手,3,1),V*0.8,V*0.2);
散戶3:=IF(換手<1,V*0.9,V*0.1);
散戶動向:(散戶1+散戶2+散戶3)/3,coloryellow,LINETHICK0;
mv1:=ema(v,9);
mv2:=ema(v,34);
FILLRGN(mv1,mv2,mv1>mv2),coloryellow;
FILLRGN(mv1,mv2,mv1<mv2),colorff9900;
FILLRGN(mv1,mv2,mv1>mv2,RGB(155,0,0),mv1<mv2,RGB(0,150,0)),LINETHICK1;
FILLRGN(主力動向,散戶動向,主力動向>=散戶動向,RGB(255,0,0),主力動向<散戶動向,RGB(0,250,0)),LINETHICK1;


{換手明細 飛狐源碼}
換手:VOL*100/CAPITAL,STICK;
hs:=FLOOR(SUM(v,0)/CAPITAL);
a:=IF(hs>0,hs,0);
aa:=IF(a-REF(a,1)>0,a,0);
▲完全換手:DRAWICON(aa>0,0,8),Color0000FF;//計算個股完全換手周期,也就從上一個紅三角到下一次紅三角之間實現了一次近似100%的換手
b:=DATACOUNT-BARPOS+1;
Wb:=BARSLAST(SYSPARAM(1)=BARPOS)+1;
換手率1:=SUM(換手,Wb);
累計換手:=REFX(換手率1,Wb[DATACOUNT]-1);//倒算累計換手
DRAWTEXT(SYSPARAM(1)=BARPOS,hhv(換手,SYSPARAM(2)),'累計'+NUMTOSTR(b[SYSPARAM(1)],0)+'天'+'換手: '
+NUMTOSTR(累計換手[SYSPARAM(1)],2)+'% '),ALIGN2,COLORRED;//顯示倒算累計換手的日線時間和累計換手率
VERTLINE(SYSPARAM(1)=BARPOS),LINEDOT,Color808080;
VERTLINE(SYSPARAM(3)=BARPOS and b),LINEDOT,Color808080;//取點位置,
今成交量:=VOL;
{換手:VOL*100/CAPITAL,STICK;}
量比:VOL/MA(VOL,5);
STICKLINE(換手<=1,0,VOL,6,0),COLORWHITE;
STICKLINE(換手>1 AND 換手<=3 ,0,VOL,6,0),color00FF00;
STICKLINE(換手>3 AND 換手<=5 ,0,VOL,6,0),colorf0f000;
STICKLINE(換手>5 AND 換手<=8 ,0,VOL,6,0),COLOR8788F6;
STICKLINE(換手>8 AND 換手<=10 ,0,VOL,6,0),coloryellow;
STICKLINE(換手>10 AND 換手<=15 ,0,VOL,6,0),COLORff00ff;
STICKLINE(換手>15 ,0,VOL,6,0),COLORRED;
DRAWTEXTEX(1,0,0,15,'當日巨大換手股價且在高位,主力出貨。低位多日充分換手,主力要拉升。開啟光見下面累計結果'),COLORRED;
DRAWTEXTEX(1,0,0,30,'換手小于1%■■白色柱地量'),COLORWHITE;
DRAWTEXTEX(1,0,0,45,'換手1-3% ■■新綠柱低靡'),color00FF00;
DRAWTEXTEX(1,0,0,60,'換手3-5% ■■淡蘭柱溫和'),colorf0f000;
DRAWTEXTEX(1,0,200,30,'換手5-8% ■■淡黃柱活躍'),COLOR8788F6;
DRAWTEXTEX(1,0,200,45,'換手8-10%■■黃柱高度活躍'),coloryellow;
DRAWTEXTEX(1,0,400,30,'換手10-15% ■■玖紅柱放量'),COLORff00ff;
DRAWTEXTEX(1,0,400,45,'換手大于15%■■大紅柱巨量'),COLORRED;
mv1:ema(v,9),Color0057FF;
mv2:ema(v,34),ColorF1910E;
FILLRGN(mv1>mv2,mv1,mv2),color0000ff;
FILLRGN(mv1<mv2,mv1,mv2),colorff9900;主力1:=IF(換手>10,V*0.9,V*0.1);
主力2:=IF(BETWEEN(換手,8,10),V*0.8,V*0.2);
主力3:=IF(BETWEEN(換手,5,8),V*0.6,V*0.4);
主力動向:(主力1+主力2+主力3)/3,colorred,LINETHICK1;
散戶1:=IF(BETWEEN(換手,5,3),V*0.6,V*0.4);
散戶2:=IF(BETWEEN(換手,3,1),V*0.8,V*0.2);
散戶3:=IF(換手<1,V*0.9,V*0.1);
散戶動向:(散戶1+散戶2+散戶3)/3,coloryellow,LINETHICK1;
FILLRGN(主力動向>=散戶動向,主力動向,散戶動向),COLOR3333FF;
FILLRGN(主力動向<=散戶動向,主力動向,散戶動向),COLOR00FF00;

{換手明細 通達信 大智慧1版}
歷史量比:VOL/MA(VOL,5);
換手:VOL*100/CAPITAL,STICK;
二日換手:SUM(換手,2);
三日換手:SUM(換手,3);
五日換手:SUM(換手,5);
十日換手:SUM(換手,10);
二十日換手:SUM(換手,20);
三十日換手:SUM(換手,30);

STICKLINE(換手<=1,0,VOL,3,0),COLORWHITE;
STICKLINE(換手>1 AND 換手<=3 ,0,VOL,3,0),COLOR00FF00;
STICKLINE(換手>3 AND 換手<=5 ,0,VOL,3,0),COLORF0F000;
STICKLINE(換手>5 AND 換手<=8 ,0,VOL,3,0),COLOR8788F6;
STICKLINE(換手>8 AND 換手<=10 ,0,VOL,3,0),COLORYELLOW;
STICKLINE(換手>10 AND 換手<=15 ,0,VOL,3,0),COLORFF00FF;
STICKLINE(換手>15 ,0,VOL,3,0),COLORRED;

DRAWTEXT(換手<=1,VOL+1000,'1'),COLORYELLOW;
DRAWTEXT(換手>1 AND 換手<=3,VOL+1000,'1'),COLORYELLOW;
DRAWTEXT(換手>3 AND 換手<=5,VOL+1000,'3'),COLORYELLOW;
DRAWTEXT(換手>5 AND 換手<=8,VOL+1000,'5'),COLORYELLOW;
DRAWTEXT(換手>8 AND 換手<=10,VOL+1000,'8'),COLORYELLOW;
DRAWTEXT(換手>10 AND 換手<=15,VOL+1000,'10'),COLORYELLOW;
DRAWTEXT(換手>15,VOL-15000,' 15'),COLORYELLOW;

{大智慧1下面不用}
主力1:=IF(換手>10,V*0.9,V*0.1);
主力2:=IF(BETWEEN(換手,8,10),V*0.8,V*0.2);
主力3:=IF(BETWEEN(換手,5,8),V*0.6,V*0.4);
主力動向:(主力1+主力2+主力3)/3,COLORRED,LINETHICK0;
散戶1:=IF(BETWEEN(換手,5,3),V*0.6,V*0.4);
散戶2:=IF(BETWEEN(換手,3,1),V*0.8,V*0.2);
散戶3:=IF(換手<1,V*0.9,V*0.1);
散戶動向:(散戶1+散戶2+散戶3)/3,COLORYELLOW,LINETHICK0;

MV1:EMA(V,9),COLOR0057FF;
MV2:EMA(V,34),COLORF1910E;
IF(MV1>MV2,MV1,DRAWNULL),COLORYELLOW;
IF(MV1<MV2,MV2,DRAWNULL),COLORFF9900;
DRAWBAND(MV1,RGB(155,0,0),MV2,RGB(0,100,0));
DRAWBAND(主力動向,RGB(255,0,0),散戶動向,RGB(0,150,0));


?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,謝謝您!)

怎么收費,代編流程等詳情請點擊閱讀,或QQ微信聯系我們!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票