您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

底背離頂背離紅買綠賣參考(指標公式副圖指標公式同花順通用演示圖)[通達信公式]

相關標簽:

?

1、參數,是自己臨時隨意設置的,因為指標是從其它地方復制而來,原本就缺少參數。
在使用過程中,可自行調整,力求達到更優化;
如果你找到了較好的參數設置,麻煩你回告我一下,謝謝!!
2、除去了原指標中的之字轉向ZIG函數,原代碼附上(txt文本),可自己再進行更優化;
3、紅柱買入,并不一定急于買入,特別是由綠柱急轉而成的紅柱;
買入時,盡量從底部買入,為的是避開風險;
當紅柱達到相對高位時,介入宜謹慎。
4、綠柱賣出,出現綠柱,一定要賣出,這更是為了避開風險;
5、在綠柱延續過程中,一定不要買入股票,堅持這一原則,并不能保證你賺錢,卻一定可以保證避開風險;
6、有了盈利,隨時可以賣出,并不一定要等到綠柱的出現,落袋為安總是不錯的選擇;
7、適用于波段操作,不怎么適用橫盤整理的時間段。本指標亦可用于期貨買賣:
出現綠色賣出線為賣出信號,預示階段頂部,后勢下跌概率較大,到轉紅為平倉信號;
出現紅色線為買進信號,預示階段底部,后勢上漲跌概率較大,到轉綠時為平倉信號。
8、最后,再說一次,避開風險,這是炒股的第一原則。做到了這一點,賺錢,就不再困難了。

?

?

原理解析:


?

?來源:程序化99( www.tzcple.tw )

源碼:

?

?


{參數:N1,N2,N3,N4}DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:= EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
AA:=ZIG(3,N4);
GG:=EMA(AA,2);
SS:IF(REF(GG,1)<GG,1,0);
XJ:IF(REF(GG,1)>GG,1,0);
VAR1:=((CLOSE - LLV(LOW,N1))/(HHV(HIGH,N1) - LLV(LOW,N1)))*(100);
VAR3:=SMA(VAR1,5,1);
K:=SMA(VAR3,3,1);
D:=SMA(K,3,1);
STICKLINE((K >= D),K,D,8,0),COLOR0000A8;
STICKLINE((K >= D),K,D,6,0),COLOR0000C0;
STICKLINE((K >= D),K,D,4,0),COLOR0000E0;
STICKLINE((K >= D),K,D,3,0),COLOR0000F0;
STICKLINE((K >= D),K,D,2,0),COLOR0000D0;
STICKLINE((K >= D),K,D,1,0),COLOR8080FF;
STICKLINE((K <= D),K,D,8,0),COLOR008800;
STICKLINE((K <= D),K,D,6,0),COLOR009900;
STICKLINE((K <= D),K,D,4,0),COLOR00AA00;
STICKLINE((K <= D),K,D,3,0),COLOR00BB00;
STICKLINE((K <= D),K,D,2,0),COLOR00CC00;
STICKLINE((K <= D),K,D,1,0),COLOR00DD00;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
K2:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
K3:=MA(K2,5);
J:=MAX(MA(C,N2),MA(C,N3));
K1:=MIN(MA(C,N2),MA(C,N3));
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
A3:=BARSLAST(REF(CROSS(K,D),1));
A4:=BARSLAST(REF(CROSS(D,K),1));
底背離:=IF(REF(LOW,A1+1)>LOW AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),1,0);
頂背離:=IF(REF(HIGH,A2+1)<HIGH AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),1,0);
底背離1:=IF(REF(LOW,A3+1)>LOW AND K>REF(K,A3+1) AND CROSS(K,D),1,0);
頂背離1:=IF(REF(HIGH,A4+1)<HIGH AND REF(D,A4+1) AND CROSS(D,K),1,0);
DRAWTEXT(CROSS(K,D) AND C>J AND D<76 AND REF(MACD,1)<MACD AND (頂背離=0 OR 頂背離1=0) AND SS=1 AND C>K2,K,'買'),COLORRED;
DRAWICON(CROSS(K,D) AND C>J AND D<76 AND REF(MACD,1)<MACD AND (頂背離=0 OR 頂背離1=0) AND SS=1 AND C>K2,K,1);
DRAWTEXT(CROSS(D,K) AND (C<K1 OR (J>=C AND C>=K)) AND REF(MACD,1)>MACD AND (底背離=0 OR 底背離1=0) AND D>18 AND XJ=1 AND C<K3,D,'賣'),COLORWHITE;
DRAWICON(CROSS(D,K) AND (C<K1 OR (J>=C AND C>=K)) AND REF(MACD,1)>MACD AND (底背離=0 OR 底背離1=0) AND D>18 AND XJ=1 AND C<K3,D,2);
DRAWTEXT(CROSS(K,D) AND (底背離=1 AND 底背離1=1) AND 頂背離1=0 AND SS=1 ,K,'買'),COLORRED;
DRAWICON(CROSS(K,D) AND (底背離=1 AND 底背離1=1) AND 頂背離1=0 AND SS=1 ,K,1);
DRAWTEXT(CROSS(D,K) AND 頂背離=1 AND 頂背離1=1 AND XJ=1,D,'賣'),COLORWHITE;
DRAWICON(CROSS(D,K) AND 頂背離=1 AND 頂背離1=1 AND XJ=1,D,2),COLORWHITE;DRAWTEXT_FIX(C>O,0.01,0.9,0,' www.tzcple.tw '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

?

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,謝謝您!)

怎么收費,代編流程等詳情請點擊閱讀,或QQ微信聯系我們!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票