您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

低點組合指標公式(指標公式三合一)公式、源碼[通達信公式]

相關標簽:

?

?

原理解析:


?

?來源:程序化99( www.tzcple.tw )

源碼:

?

?

STICKLINE(C>0,20,80.1,5,0),COLOR2F4F4F;
STICKLINE(C>0,100,80.1,5,0),COLOR5C4033;
STICKLINE(C>0,0,20.1,5,0),COLOR5C4033;
{多日K線多頭排列時,出現買進信號時可買進,持股時間依行情而定,做多;
多日K線向下空頭發散時,清倉。}
VAR3:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K13:SMA(VAR3,3,1) ;
D14:SMA(K13,3,1) ;
J13:=3*K13-2*D14;
VAR31:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
K21:=SMA(VAR31,3,1) ;
D21:=SMA(K21,3,1) ;
VAR34:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K34:=SMA(VAR34,3,1);
D34:=SMA(K34,3,1) ;
VAR55:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K55:SMA(VAR55,5,1) ,COLORGREEN,LINETHICK1;
D55:SMA(K55,5,1),COLORFF9933;
J55:=3*K55-2*D55;
DIBU:= K13<20 AND D14<20 AND K21<20 AND D21<20 AND K34<20 AND D34<20 AND K55<20 AND D55<20;
STICKLINE(DIBU=1,80,60,5.8,1),COLORRED;
TOBU:= K13>80 AND D14>80 AND K21>80 AND D21>80 AND K34>80 AND D34>80 AND K55>80 AND D55>80;
STICKLINE(TOBU=1,40,20,5.8,1),COLORGREEN;
頂部:80,COLOR55AA77,LINETHICK1;
底部:20,COLOR55AA77,LINETHICK1;
中軸線:50,POINTDOT,COLORWHITE;
天線:100, POINTDOT,COLORWHITE;
底線:0, POINTDOT,COLORWHITE;
現價:=C;{階段指標信號}
VAR2:=LLV(LOW,10);
VAR33:=HHV(HIGH,25);
動力線:= EMA((CLOSE-VAR2)/(VAR33-VAR2)*4,4);
底部2:=0.2,COLOR70DB93;
關注:=0.5,COLORYELLOW;
數值:=動力線,COLORA8A8A8;
階段底部:=CROSS(動力線,底部2);
STICKLINE(階段底部,0.2,49,1,0),COLORRED;
DRAWICON(階段底部,50,11);
階段關注:=CROSS(動力線,關注);
STICKLINE(階段關注,0.1,20,1,0),COLORMAGENTA;
階段賣出:= 3.2,COLORC6C600;
BB:=3.5,COLOR0088FF;
清倉賣出:=3.5,COLORFF75FF;
清倉:=CROSS(清倉賣出,動力線);
STICKLINE(清倉,100,70,1,0),COLORBLUE;
短線賣出:=CROSS(階段賣出,動力線);
STICKLINE(短線賣出,100,90,2,0),COLORGREEN;{信號燈指標信號}
A1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A2:=SMA(A1,3,1);
A3:=SMA(A2,3,1);
A4:=3*A2-2*A3;
X:=LLV(A4,2)=LLV(A4,8);
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX); DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳買入:=(AV + NEWVOL);
最佳買入選股:=IF(CROSS(最佳買入,0),1,0);
VAR11:=SMA(最佳買入選股,3,1);
VAR22:=SMA(VAR11,3,1);
VAR333:=SMA(VAR22,3,1);
XG:=CROSS(A4,REF(A4+0.01,1)) AND X AND A4<20 AND CROSS(VAR22,VAR333) AND VAR22<40;
STICKLINE(XG,0.2,10,2,0),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=60,90,'K值線多頭排列,做多'),COLORRED;DRAWTEXT_FIX(C>O,0.01,0.9,0,' www.tzcple.tw '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

?

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,謝謝您!)

怎么收費,代編流程等詳情請點擊閱讀,或QQ微信聯系我們!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票