您現在的位置:程序化交易>> 期貨公式>> 博易大師>> 博易大師知識>>正文內容

黃金分割線的插入 [博易POBO]

咨詢內容:

黃金分割線的插入

老師,能給一個能夠插入博易大師中主圖的黃金分割線指標嗎?

?

?來源:程序化99網( www.tzcple.tw )

博易技術人員: 這個是以波段頂為起點,波段底為終點所畫:
?短高H:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
短低L:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
B:=(短高H+短低L)/2;
D:=MA(B,10);
D14:=MA(B,14),COLORRED,LINETHICK1;
D21:=MA(B,21),COLORRED,LINETHICK2;
A1:=MA((3*C+L+O+H)/6,28);
B1:=(20*A1+19*REF(A1,1)+18*REF(A1,2)+17*REF(A1,3)+16*REF(A1,4)+15*REF(A1,5)+14*REF(A1,6)
+13*REF(A1,7)+12*REF(A1,8)+11*REF(A1,9)+10*REF(A1,10)+9*REF(A1,11)+8*REF(A1,12)
+7*REF(A1,13)+6*REF(A1,14)+5*REF(A1,15)+4*REF(A1,16)+3*REF(A1,17)+2*REF(A1,18)+
REF(A1,12))/210,COLORGREEN,LINETHICK1;
D1:=MA(B1,14),COLORGREEN,LINETHICK2;
D90H:=EMA(短高H,90),COLORRED,LINETHICK1;
D90L:=EMA(短低L,90),COLORRED,LINETHICK1;
D90差:=D90H-D90L;
D90頂:=D90H+D90差*2,COLORRED,LINETHICK1;
D90底:=D90L-D90差*2,COLORRED,LINETHICK1;
D90HH:=D90H-D90差*0.1,COLORRED,LINETHICK1;
D90LL:=D90L+D90差*0.1,COLORRED,LINETHICK1;
高0:=(MA(MA(H,30),30)-MA(MA(L,30),30))*1+MA(MA(H,30),30);
低0:=MA(MA(L,30),30)-(MA(MA(H,30),30)-MA(MA(L,30),30))*1;
多頭定位:=低0>=D90底 AND 高0>=D90頂;
空頭定位:=高0<=D90頂 AND 低0<=D90底;
震蕩定位:=低0>=D90底 AND 高0<=D90頂;
波段頂00:=(MA(MA(H,60),60)-MA(MA(L,60),60))*2.6+MA(MA(H,60),60);
波段底00:=MA(MA(L,60),60)-(MA(MA(H,60),60)-MA(MA(L,60),60))*2.6;
STICKLINE(1=1,D90HH,D90LL,5,0),COLORGRAY;
做空:(MA(MA(H,30),30)-MA(MA(L,30),30))*1+MA(MA(H,30),30),LINETHICK2,COLORWHITE;
做多:MA(MA(L,30),30)-(MA(MA(H,30),30)-MA(MA(L,30),30))*1,LINETHICK2,COLORWHITE;
波段頂:(MA(MA(H,60),60)-MA(MA(L,60),60))*2.6+MA(MA(H,60),60),LINETHICK2,COLORYELLOW;
波段底:MA(MA(L,60),60)-(MA(MA(H,60),60)-MA(MA(L,60),60))*2.6,LINETHICK2,COLORYELLOW;
B0:=(短高H+短低L)/2;
D0:=MA(B0,10);
DRAWTEXT(ISLASTBAR,做空,'空'),COLORGREEN;
DRAWTEXT(ISLASTBAR,做多,'多'),COLORRED;
DRAWTEXT(ISLASTBAR,波段頂,'頂'),COLORGREEN;
DRAWTEXT(ISLASTBAR,波段底,'底'),COLORRED;
MACD價格:=EMA(CLOSE,3) - EMA(CLOSE,9);
DEA33:=EMA((EMA(MACD價格,3) - EMA(MACD價格,9)),9),COLORWHITE,LINETHICK0;
DEA333:=REF(DEA33,1),COLORWHITE,LINETHICK0;
STICKLINE(DEA333<=DEA33,LOW,HIGH,0,0),COLORRED;?
STICKLINE(DEA333<=DEA33,CLOSE,OPEN,3,0),COLORRED;?
STICKLINE(DEA333>=DEA33,LOW,HIGH,0,0),COLORGREEN;?
STICKLINE(DEA333>=DEA33,CLOSE,OPEN,3,0),COLORGREEN;?
CCI3:=((H+L+C)/3-MA((H+L+C)/3,3))/(0.015*AVEDEV((H+L+C)/3,3));
STICKLINE(L<做多 AND CROSS(CCI3,-50) AND REF(CCI3,1)<0,LOW,HIGH,0,0),COLORMAGENTA;?
STICKLINE(L<做多 AND CROSS(CCI3,-50) AND REF(CCI3,1)<0,CLOSE,OPEN,3,0),COLORMAGENTA;?
STICKLINE(H>做空 AND CROSS(50,CCI3) AND REF(CCI3,1)>0,LOW,HIGH,0,0),COLORWHITE;?
STICKLINE(H>做空 AND CROSS(50,CCI3) AND REF(CCI3,1)>0,CLOSE,OPEN,3,0),COLORWHITE;
多頭趨勢:=多頭定位=1 OR 震蕩定位=1;
空頭趨勢:=震蕩定位=1 OR 空頭定位=1;
多:=多頭趨勢=1 AND L<做多 AND CROSS(CCI3,-50) AND REF(CCI3,1)<0;
空:=空頭趨勢=1 AND H>做空 AND CROSS(50,CCI3) AND REF(CCI3,1)>0;
DRAWSL(ISLASTBAR,波段底+0.382*(波段頂-波段底),0,BARPOS,1);
DRAWSL(ISLASTBAR,波段底+0.5*(波段頂-波段底),0,BARPOS,1);
DRAWSL(ISLASTBAR,波段底+0.618*(波段頂-波段底),0,BARPOS,1); 在副圖中能用嗎? 來源 程序化久久網

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,謝謝您!)

怎么收費,代編流程等詳情請點擊閱讀,或QQ微信聯系我們!


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
双色球机选新浪彩票