您現在的位置:程序化交易>> 股票公式>> 同花順>> 同花順公式>>正文內容

主要成交量公式、源碼[同花順公式]

相關標簽:同花順逃頂指標源碼 、 同花順pvi指標源碼 、 同花順macd指標源碼 、 同花順虛擬成交量公式 、 同花順魔鬼公式源碼 、 同花順板塊公式源碼 、 同花順股票公式源碼 、 同花順選股公式源碼 、 同花順ddx公式源碼 、 同花順公式源碼說明 、 同花順公式源碼2017 、 同花順dde公式源碼 、

?

有關成交量的一個指標,供大家學習研究使用。

?

?

原理解析:


?

?來源:程序化99( www.tzcple.tw )

源碼:

?

?

?

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,55),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=EMA(CLOSE,5);
VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
VAR11:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*(-1);
VAR12:=EMA(CLOSE,5)*(-1);
備錢:=IF(VAR8>REF(VAR8,1),0,VAR8),COLOR0FFFFF;
界:0,COLORFFFFFF,LINETHICK1;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
啟動:=IF(XL3,0,VAR8*3),colorred;
VA:=(2*C+H+L)/4;
VB:=LLV(L,5);
VC:=HHV(H,5);
紅線上穿買:EMA((VA-VB)/(VC-VB)*27,5),colorred;
紅線下穿賣:EMA(紅線上穿買,3),COLORFFFF00;
散戶:=EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,5))/(HHV(HIGH,4)-LLV(LOW,5))*100,4);
莊家:=EMA(0.667*REF(散戶,1)+0.333*散戶,2);
DRAWTEXT(CROSS(散戶,莊家) AND 散戶<30,5,'進'),COLOR00FF00;
DRAWTEXT(CROSS(莊家,散戶) AND 散戶>70,18,'出'),COLOR00FF00;
極品底:=IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),LINETHICK2,COLORFFFFFF;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<19,3,'買'),COLORFFFF00;
QVAR1A:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;
QVAR1B:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
QVAR1C:=SMA(QVAR1B,13,8);
QVAR1D:=SMA(QVAR1A,21,8);
機會來臨:=SMA(QVAR1C,13,8),colorred;
AAS:=FILTER((COUNT((機會來臨-QVAR1D<(-65)),3)=3),34);
波段買點:IF(AAS,15,0),COLORFFFFFF;
DRAWTEXT(波段買點,17,'波段買'),COLORFFFFFF;TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' www.tzcple.tw '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花順程序化交易');

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 1145508240  點擊這里給我發消息進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票