您現在的位置:程序化交易>> 股票公式>> 同花順>> 同花順公式>>正文內容

大盤牛熊線牛市熊市副圖指標公式源碼[同花順公式]

相關標簽:大盤副圖指標源碼貼圖 、 牛熊分界線指標源碼 、 同花順主圖公式源碼 、 同花順大盤趨勢線公式 、 牛回頭指標公式源碼 、 同花順牛熊線怎么看 、 同花順觀察線指標公式 、 祝利榮牛熊線指標公式 、 牛熊市的秘密指標 、 同花順使用的副圖指標 、 同花順主圖指標公式 、 同花順分時指標源碼 、 同花順畫線指標源碼 、 大盤牛熊線通達信主圖 、

?

觀察牛熊市,判斷股市周期!

?

?

?

原理解析:


?

?來源:程序化99( www.tzcple.tw )

源碼:

?

?

均價:=(HIGH+LOW+CLOSE)/3;
VAR1:=LLV(LOW,12);
VAR2:=HHV(HIGH,5);
快線:=EMA((均價-VAR1)/(VAR2-VAR1)*100,4);
慢線:=EMA(0.667*REF(快線,1)+0.333*快線,2);
轉點:=IF(快線>慢線,1,0);
頂部:75,DOTLINE,COLOR3C3CFF,PRECIS0;
底部:25,DOTLINE,colorcyan,PRECIS0;
大盤均價:=(INDEXH+INDEXL+INDEXC)/3;
個股LC:=REF(均價,1);
個股牛熊:=SMA(MAX(均價-個股LC,0),28,1)/SMA(ABS(均價-個股LC),28,1)*100,coloryellow,PRECIS2;
PARTLINE(個股牛熊,個股牛熊>REF(個股牛熊,1),RGB(250,30,250),個股牛熊<=REF(個股牛熊,1),RGB(30,250,250)),LINETHICK3;
FILLRGN(個股牛熊,50,個股牛熊>50,RGB(155,50,50)),PRECIS2;
FILLRGN(個股牛熊,50,50>個股牛熊,RGB(0,100,50)),PRECIS2;
FILLRGN(個股牛熊,75,個股牛熊>75,RGB(100,0,100)),PRECIS2;
FILLRGN(個股牛熊,25,25>個股牛熊,RGB(50,0,155)),PRECIS2;
大盤LC:=REF(大盤均價,1);
大盤牛熊:SMA(MAX(大盤均價-大盤LC,0),28,1)/SMA(ABS(大盤均價-大盤LC),28,1)*100,coloryellow,PRECIS2;
STICKLINE(轉點=1,50,50,6,0),coloryellow;
STICKLINE(轉點=0,50,50,6,0),colorcyan;TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' www.tzcple.tw '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花順程序化交易');

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

均價:=(HIGH+LOW+CLOSE)/3;
VAR1:=LLV(LOW,12);
VAR2:=HHV(HIGH,5);
快線:=EMA((均價-VAR1)/(VAR2-VAR1)*100,4);
慢線:=EMA(0.667*REF(快線,1)+0.333*快線,2);
轉點:=IF(快線>慢線,1,0);
頂部:75,DOTLINE,COLOR3C3CFF,PRECIS0;
底部:25,DOTLINE,colorcyan,PRECIS0;
大盤均價:=(INDEXH+INDEXL+INDEXC)/3;
個股LC:=REF(均價,1);
個股牛熊:=SMA(MAX(均價-個股LC,0),28,1)/SMA(ABS(均價-個股LC),28,1)*100,coloryellow,PRECIS2;
PARTLINE(個股牛熊,個股牛熊>REF(個股牛熊,1),RGB(250,30,250),個股牛熊<=REF(個股牛熊,1),RGB(30,250,250)),LINETHICK3;
FILLRGN(個股牛熊,50,個股牛熊>50,RGB(155,50,50)),PRECIS2;
FILLRGN(個股牛熊,50,50>個股牛熊,RGB(0,100,50)),PRECIS2;
FILLRGN(個股牛熊,75,個股牛熊>75,RGB(100,0,100)),PRECIS2;
FILLRGN(個股牛熊,25,25>個股牛熊,RGB(50,0,155)),PRECIS2;
大盤LC:=REF(大盤均價,1);
大盤牛熊:SMA(MAX(大盤均價-大盤LC,0),28,1)/SMA(ABS(大盤均價-大盤LC),28,1)*100,coloryellow,PRECIS2;
STICKLINE(轉點=1,50,50,6,0),coloryellow;
STICKLINE(轉點=0,50,50,6,0),colorcyan;TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' www.tzcple.tw '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花順程序化交易');

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 1145508240  點擊這里給我發消息進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票