您現在的位置:程序化交易>> 期貨公式>> 文華財經>> 文華財經公式>>正文內容

波段王指標抄底工具指標源碼[文華財經公式]

波段王指標源碼:


HH:=HHV(HIGH,40);
LL:=LLV(LOW,40);?
HH1:=BARSLAST((HH > REF(HH,1)));?
LL1:=BARSLAST((LL < REF(LL,1)));?
PARTLINE((HH1 < LL1),LL,COLORYELLOW);?
PARTLINE((HH1 > LL1),HH,COLORBLUE);?
STICKLINE((HH1 < LL1),CLOSE,OPEN,COLORRED,0);?
DRAWLINE((HH1 < LL1),HIGH,(HH1 < LL1),LOW,COLORRED);?
STICKLINE((HH1 > LL1),CLOSE,OPEN,COLORGREEN,0);?
DRAWLINE((HH1 > LL1),HIGH,(HH1 > LL1),LOW,COLORGREEN);?
DRAWTEXT(CROSS(HH1,LL1),HH,'空'); DRAWTEXT(CROSS(LL1,HH1),LL,'多'); //信號顯示
DRAWTEXT(((HH1 < REF(HH1,1)) && (HH1 < LL1)),LOW,'♂加多'); //顯示加多信號
DRAWTEXT(((LL1 < REF(LL1,1)) && (HH1 > LL1)),HIGH,'♀加空'); //顯示加空

?

抄底工具源碼:


參數:
[N1,5.000000,250.000000,125.000000]? //參數為125
[N2,1.000000,20.000000,5.000000]//參數為5
[N3,5.000000,60.000000,20.000000]//參數為20


HX:=HHV(HIGH,3); LX:=LLV(LOW,3);
H1:=IFELSE(HX<REF(HX,1)&&HX<REF(HX,2)&&HX<REF(HX,4)&&LX<REF(LX,1)&&LX<REF(LX,3)&&LX<REF(LX,5)&&OPEN>CLOSE&&(HHV(OPEN,0)-CLOSE)>0,REF(HX,4),0);
L1:=IFELSE(LX>REF(LX,1)&&LX>REF(LX,3)&&LX>REF(LX,5)&&HX>REF(HX,1)&&HX>REF(HX,2)&&HX>REF(HX,4)&&OPEN<CLOSE&&(CLOSE-LLV(OPEN,0))>0,REF(LX,4),0);
H2:=VALUEWHEN(H1>0,H1); L2:=VALUEWHEN(L1>0,L1);
K1:=IFELSE(CLOSE>H2,-3,IFELSE(CLOSE<L2,1,0));
K2:=VALUEWHEN(K1<>0,K1);G:=IFELSE(K2=1,H2,L2);?
G1:=VALUEWHEN(ISLASTBAR,G);DRAWNUMBER(LX>0,G1,G1,0,COLORCYAN);?
TMP:=K2;W1:=K2; W2:=OPEN-CLOSE;?
HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE);?
LT:=IFELSE(OPEN<CLOSE,OPEN,CLOSE);?
DRAWLINE(W1=1,HIGH,W1=1,HT,COLORCYAN);?
DRAWLINE(W1=1,LOW,W1=1,LT,COLORCYAN);?
DRAWLINE(W1=-3,HIGH,W1=-3,HT,COLORRED);?
DRAWLINE(W1=-3,LOW,W1=-3,LT,COLORRED);?
STICKLINE(W1>0,OPEN,CLOSE,COLORCYAN,1);?
STICKLINE(W1<=0,OPEN,CLOSE,COLORRED,1);?
STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,COLORRED,0);?
STICKLINE(W2>0&&W1>0,OPEN,CLOSE,COLORCYAN,0);?
DRAWLINE(TMP=1&&REF(TMP,1)=1,G,TMP=1&&REF(TMP,1)=1,REF(G,1),COLORCYAN);DRAWLINE(TMP=-3&&REF(TMP,1)=-3,G,TMP=-3&&REF(TMP,1)=-3,REF(G,1),COLORRED);
DRAWSL(K2=1,G,0,1,0,COLORCYAN);DRAWSL(K2=-3,G,0,1,0,COLORRED); DRAWTEXT(CROSS(TMP,0),HX,'賣'); DRAWTEXT(CROSS(0,TMP),LX,'買'); MA55:=MA(CLOSE,55); DRAWTEXT(CROSS(TMP,0)&&CLOSE<=MA55,HX,'賣↓'); DRAWTEXT(CROSS(0,TMP)&&CLOSE>=MA55,LX,'買↑');

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 1145508240  點擊這里給我發消息進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票