您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

階梯線 版[其他軟件公式]

相關標簽:

?

?

原理解析:


?

?來源:程序化99( www.tzcple.tw )

源碼:

?

?

?

?

{階梯線}
input:n(5,1,600),m(10,1,600);
STICKLINE(CLOSE>= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE>= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000066;
STICKLINE(CLOSE>= REF(CLOSE,1) ,OPEN,CLOSE,2.6,0 ),COLOR000099;
STICKLINE(CLOSE>= REF(CLOSE,1) ,OPEN,CLOSE,2,0 ),COLOR0000CC;
STICKLINE(CLOSE>= REF(CLOSE,1) ,OPEN,CLOSE,1.2,0 ),COLOR0000FF;
STICKLINE(CLOSE>= REF(CLOSE,1) ,OPEN,CLOSE,0.4,0 ),COLORCC66FF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.6,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.2,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.4,0 ),COLORCYAN;
AA10:MA(C,N);
BB10:=ATAN((AA10-REF(AA10,1)))*180/3.1416;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),3,1),COLOR000066;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),2.6,1),COLOR000099;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),2,1),COLOR0000CC;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),1.2,1),COLOR0000FF;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),0.4,1),COLORCC66FF;
STICKLINE(BB10<1 AND AA10< REF(AA10,1), AA10,REF(AA10,1),3,1),COLOR007700;
STICKLINE(BB10<1 AND AA10< REF(AA10,1), AA10,REF(AA10,1),2.6,1),COLOR009900;
STICKLINE(BB10<1 AND AA10< REF(AA10,1), AA10,REF(AA10,1),2,1),COLOR00BB00;
STICKLINE(BB10<1 AND AA10< REF(AA10,1), AA10,REF(AA10,1),1.2,1),COLOR00DD00;
STICKLINE(BB10<1 AND AA10< REF(AA10,1), AA10,REF(AA10,1),0.4,1),COLOR00FF00;
AA20:MA(C,M);
BB20:=ATAN((AA20-REF(AA20,1)))*180/3.1416;
STICKLINE(BB20>1,AA20,REF(AA20,1),3,1),COLOR00AAFF;
STICKLINE(BB20>1,AA20,REF(AA20,1),2.6,1),COLOR00CCFF;
STICKLINE(BB20>1,AA20,REF(AA20,1),2,1),COLOR22FFFF;
STICKLINE(BB20>1,AA20,REF(AA20,1),1.2,1),COLOR66FFFF;
STICKLINE(BB20>1,AA20,REF(AA20,1),0.4,1),COLOR99FFFF;
STICKLINE(BB20<1,AA20,REF(AA20,1),3,1),COLOR777777;
STICKLINE(BB20<1,AA20,REF(AA20,1),2.6,1),COLOR999999;
STICKLINE(BB20<1,AA20,REF(AA20,1),2,1),COLORBBBBBB;
STICKLINE(BB20<1,AA20,REF(AA20,1),1.2,1),COLORDDDDDD;
STICKLINE(BB20<1,AA20,REF(AA20,1),0.4,1),COLORFFFFFF;

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  有需要幫忙請點擊這里留言!!!或微信:cxhjy888 進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票