您現在的位置:程序化交易>> 期貨公式>> 文華財經>> 文華財經知識>>正文內容

[求助]把通達信副圖修改成文華的macd背離指標 [文華財經]

  • 咨詢內容: ?DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:EMA(DIFF,9);
    MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
    低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
    STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;
    DRAWTEXT(低位金叉,0.16,'低位金叉',COLORWHITE;
    JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
    二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
    STICKLINE(二次金叉,0,0.06,6,0),COLORFF00FF;
    DRAWICON(二次金叉,DEA*0.9,1) ;
    DRAWTEXT(二次金叉,0.2,'二次金叉',COLORYELLOW;
    A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
    底背離:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
    STICKLINE(底背離,0,0.03,6,0),COLOR00FF00;
    底背:DRAWLINE(A1=0,DEA,底背離,DEA,0),COLORRED,LINETHICK4;
    DRAWTEXT(底背離,0.12,'底背離',COLORFF00FF;
    A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
    頂背離:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
    頂背:DRAWLINE(A2=0,DEA,頂背離,DEA,0),COLORGREEN,LINETHICK4;?
    DRAWTEXT(低位金叉 AND 二次金叉 AND 底背離,0.25,'全項',COLOR0000FF,LINETHICK2

    ?

    ?來源:程序化99

  • 文華技術人員:

    參考:、

    ?

    DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:EMA(DIFF,9);
    MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
    低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
    STICKLINE1(低位金叉,0,0.08,6,0),COLORYELLOW;
    DRAWTEXT(低位金叉,0.16,'低位金叉',COLORWHITE;
    JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
    二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
    STICKLINE1(二次金叉,0,0.06,6,0),COLORFF00FF;
    DRAWICON(二次金叉,DEA*0.9,1) ;
    DRAWTEXT(二次金叉,0.2,'二次金叉',COLORYELLOW;
    A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
    底背離:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
    STICKLINE1(底背離,0,0.03,6,0),COLOR00FF00;
    底背:TRENDLINES(A1=0,DEA,底背離,DEA),COLORRED,LINETHICK4;
    DRAWTEXT(底背離,0.12,'底背離',COLORFF00FF;
    A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
    頂背離:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
    頂背:TRENDLINES(A2=0,DEA,頂背離,DEA),COLORGREEN,LINETHICK4;
    DRAWTEXT(低位金叉 AND 二次金叉 AND 底背離,0.25,'全項',COLOR0000FF,LINETHICK2;

    ?

    ?來源: www.tzcple.tw

  • 文華客服: 指標不對啊,裝上顯示這個,和通達信不一樣,頂背離綠線連接,底背離紅線連接,


    文件名:2.png



    下面的是通達信的


    文件名:tdx.png
    ? ?

    ?

  • 網友回復: ?不同軟件函數機制不同,效果可能存在差異,是正常的
    您可以整理下完整的思路量化表達,我們在文華軟件直接為您分析編寫

    ?

  • 網友回復: ?http://help.wenhua.com.cn/dispbbs.asp?boardid=14&Id=698736# 可以根據系統的這個頂底背離, ?把背離區域用線連接起來
    頂背離區域用綠色連接,底背離用紅色線連接起來

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  點擊這里給我發消息或微信:cxhjy888 進行 有償 編寫!不貴!點擊查看價格!


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
双色球机选新浪彩票