您現在的位置:程序化交易>> 股票公式>> 同花順>> 同花順公式>>正文內容

情報天線副圖指標公式、源碼[同花順公式]

相關標簽:

?

?

原理解析:


?

?來源:程序化99( www.tzcple.tw )

源碼:

?

?

?

?

Var1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
Var2:=2*ABS(Var1);
Var3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var5:=(HIGH+LOW+CLOSE)/3;
Var6:=(Var5-MA(Var5,14))/(0.015*AVEDEV(Var5,14));
Var7:=(Var5-MA(Var5,70))/(0.015*AVEDEV(Var5,70));
Var8:=IF(Var6>=150 AND Var6<200 AND Var7>=150 AND Var7<200,10,0);
Var9:=IF(Var6<=-150 AND Var6>-200 AND Var7<=-150 AND Var7>-200,-10,Var8);
VarA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VarB:=100-ABS(VarA);
VarC:=3*SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VarD:=3*SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VarE:=REF(LOW,1)*0.9;
VarF:=LOW*0.9;
Var10:=(VarF*VOL+VarE*(CAPITAL-VOL))/CAPITAL;
Var11:=EMA(Var10,30);
Var12:=Var11-CLOSE;
Var13:=REF(CLOSE,1);
Var14:=SMA(MAX(CLOSE-Var13,0),7,1)/SMA(ABS(CLOSE-Var13),7,1)*100;
Var15:=SMA(MAX(CLOSE-Var13,0),13,1)/SMA(ABS(CLOSE-Var13),13,1)*100;
Var16:=BARSCOUNT(CLOSE);
Var17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
Var18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
Var19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var1A:=(SMA(Var19,4,1)-50)*2;
Var1B:=SMA(Var1A,3,1);
Var1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var1D:=SMA(Var1C,4,1);
Var1E:=SMA(Var1D,3,1);
Var1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Var20:=IF(Var17<=25 AND Var18<-95 AND Var1F>20 AND Var1B<-30 AND Var1E<30 AND Var12>=-0.25 AND Var14<22 AND Var15<28 AND Var16>50,80,0);
情報: Var3;
天線: IF(VarB<90,VarB,100);
紅軍: IF(Var1>0,Var1,0),colorred, LINESTICK;
綠軍: IF(Var1<0,Var2,0),colorgreen,LINESTICK;
導彈: Var20;
預警系統: IF(Var7>=200 AND Var6>=150,15,IF(Var7<=-200 AND Var6<=-150,-15,Var9))+60;
STICKLINE(Var3>=REF(Var4,1),Var3,Var4,8,0);
STICKLINE(Var3<REF(Var4,1),Var3,Var4,8,0);
Var21:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
Var22:=CLOSE<MA(CLOSE,20) AND MA(CLOSE,20)<REF(MA(CLOSE,20),1);
Var23:=紅軍>50 AND 預警系統>60 AND 天線=100;
Var24:=紅軍>48 AND 預警系統>60 AND 天線<100;
Var25:=綠軍>38 AND 預警系統<55;
Var26:=導彈>50 AND 天線<90;
Var27:=Var3<REF(Var4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
Var28:=Var3>=REF(Var4,1) AND CLOSE<REF(CLOSE,1) AND 預警系統=60 AND 導彈=0 AND 綠軍>=REF(綠軍,1) AND VarC<REF(VarD,1);
DRAWTEXT(Var21 AND COUNT(Var21,30)=1,100,'上升通道,持股待長或高拋低吸!');
DRAWTEXT(Var22 AND COUNT(Var22,30)=1,90,'下降通道,小心無量陰跌! ');
DRAWTEXT(Var23 AND COUNT(Var23,30)=1,70,'上漲過急,需要調整,短線先拋出! ');
DRAWTEXT(Var24 AND COUNT(Var24,30)=1,80,'莊家出貨,大跌在即,中線拋出! ');
DRAWTEXT(Var25 AND COUNT(Var25,30)=1,50,'不必殺跌,應有小反彈 ,跌停除外!');
DRAWTEXT(Var26 AND COUNT(Var26,30)=1,30,'堅決搶反彈,但巨量封跌停除外 ');
DRAWTEXT(Var27 AND COUNT(Var27,30)=1,40,'有大資金進場跡象,關注!');
DRAWTEXT(Var28 AND COUNT(Var28,30)=1,20,'見頂回落');
買入:IF(VAR27 AND COUNT(VAR27,30)=1,100,0),LINETHICK3,colorblue;
RSV89:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100;
k89:SMA(RSV89,13,1),ColorffFF00,LINETHICK3;
RSV3:=(CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3))*100;
K3:=SMA(RSV3,3,1),COLOR00FFFF,LINETHICK3;
d3:=SMA(K3,3,1);
J3:3*K3-2*d3,ColoraaaAAA;
V50:50;
V20:20;
V80:80;TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' www.tzcple.tw '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花順程序化交易');

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 1145508240  點擊這里給我發消息進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票