您現在的位置:程序化交易>> 期貨公式>> 文華財經>> 文華財經公式>>正文內容

文華峰波峰波谷指標[文華財經公式]

 

源碼:

TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1);
B1:=FILTER(A1,10);
C1:=BACKSET(B1,10+1);
HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1);
B2:=FILTER(A2,10);
C2:=BACKSET(B2,10+1);
LD:=FILTER(C2,10);
AZ1:=REF(C,BARSLAST(HD));
B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD);//www.tzcple.tw
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波峰:IF(T1,AZ1,AZ1),POINTDOT,COLOR0000FF,LINETHICK3;
STICKLINE(T1,AZ1,AZ1,9,0),COLOR0000FF,LINETHICK2;
波谷:IF(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK3;
STICKLINE(T2,B,B,9,0),COLOR80FF00,LINETHICK2;

 

解析:

TY賦值:收盤價
A1賦值:10日前的TY=2*10+1日內TY的最高值
B1賦值:A1的10日過濾
C1賦值:若B1則將最近10+1周期置為1
HD賦值:C1的10日過濾
A2賦值:10日前的TY=2*10+1日內TY的最低值
B2賦值:A2的10日過濾
C2賦值:若B2則將最近10+1周期置為1
LD賦值:C2的10日過濾
AZ1賦值:上次HD距今天數日前的收盤價
B賦值:上次LD距今天數日前的收盤價
T2賦值:上次HD距今天數>上次LD距今天數 AND 取反
輸出波峰:如果T1,返回AZ1,否則返回AZ1,POINTDOT,COLOR0000FF,線寬為3
當滿足條件T1時,在AZ1和AZ1位置之間畫柱狀線,寬度為9,0不為0則畫空心柱.,COLOR0000FF,線寬為2
輸出波谷:如果T2,返回B,否則返回B,COLOR80FF00,POINTDOT,線寬為3
當滿足條件T2時,在B和B位置之間畫柱狀線,寬度為9,0不為0則畫空心柱.,COLOR80FF00,線寬為2
 

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 1145508240  點擊這里給我發消息進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票