您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

東濱西湊主圖指標公式源碼[大智慧公式]

相關標簽:大智慧指標公式源碼 、 現貨主圖指標公式源碼 、 大智慧指標源碼 、 大智慧飽和度指標源碼 、 大智慧跨周期指標源碼 、 大智慧主升浪指標公式 、 大智慧公式源碼 、 大智慧絕品主圖指標 、 黃藍帶主圖指標源碼 、 均線買賣主圖指標源碼 、 強勢牛股主圖指標源碼 、 通達信主圖指標源碼 、 波浪指標主圖指標源碼 、 好用主圖指標 源碼 、 黃金坑指標源碼主圖 、

 

大智慧東濱西湊主圖 源碼我說明這個主圖里邊的東西.完完全全是【拿來】的.只不過我編輯一下.我根本沒有創造.就是【東濱西湊】而已--------我也沒能耐創造-------但是我看還是可以用的----從歷史K線上看還可以-------在其他周期也能用源碼

 

 

原理解析:


 

 

源碼:

 

DRAWGBKLAST(1,STRIP(RGB(0,0,80),RGB(0,20,20),0));
{K線JHJ}
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR0000AA;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000EE;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;
A74:=MA(CLOSE,20);
A75:=(CLOSE > MA(CLOSE,5));
A76:=(MA(CLOSE,5) > MA(CLOSE,10));
A77:=(CLOSE > MA(CLOSE,10));
A78:=(MA(CLOSE,5) > MA(CLOSE,20));
A79:=(CLOSE > MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74 > A710);
AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10))) + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);T := BARSLAST(DISPSTATUS=1)+1;
T := BARSLAST(DISPSTATUS=1)+1;
HHg := HHV(H, T);
ddg := LLV(L, T);
{Hk := LL-HH; G12 := LL-HK*1.55; }
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'該股的量能理想,有明顯走強跡象,可以考慮中線進場參與,倉位在2/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'該股雖然走勢趨強,但量能還顯不足,可以考慮短線進場,倉位在1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'該股量價配合良好,但相對其它股票并沒有明顯走強,可以考慮短線進場,倉位1/2左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'該股形態尚可,但量能不足,股票也未完全走強,可以短線參與,倉位1/3左右。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'該股形態變壞,但走勢相對其它股票尚可,重倉者減持大半,清倉者可以觀望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'該股隨大盤一起下跌,程明顯縮量走勢,考慮到大盤風險,減持或清倉。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'該股放量下跌,走勢明顯偏弱,離場觀望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'該股縮量下跌,走勢偏弱,離場觀望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'該股形態良好,強勢明顯,量能充足,可以繼續持有。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'該股上行趨勢不變,強勢依然,但量能開始轉弱,注意風險。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'該股仍然具備上漲潛力,但股性偏弱,可考慮減倉。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'該股走勢趨弱,量能不足,減持大部分籌碼。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'該股形態不佳,注意成交量的變化,但目前不適合參與。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
DRAWTEXTABS(12,50,'該股趨勢不明,股價偏弱,注意量能變化,目前不宜參與。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'該股有走強跡象,但量能不足,趨勢不明,不適合操作。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
DRAWTEXTABS(12,50,'該股走勢太弱,沒有參與價值。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,50,'大盤量能理想,有明顯走強跡象,可以考慮中線進場參與,倉位在2/3左右, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,50,'如前期經過一輪下跌,此時為最佳買點,但如果前期有過一段漲幅則介入需謹慎。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(12,50,'大盤雖然走勢趨強,但量能還顯不足,如果前期經過一輪下跌, '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
DRAWTEXTABS(12,50,'可以考慮短線進場,倉位在1/2左右,一旦量能放大可以加倉買入。 '),color0000FF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,50,'大盤形態走壞,重倉者可以減去大部分倉位。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 < V2)) THEN
DRAWTEXTABS(12,50,'大盤縮量調整,注意風險,短線清倉觀望。 '),color00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,50,'大盤走勢良好,量能理想,可以繼續持有強勢股。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(12,50,'大盤形態良好,但量能稍顯不足,隨時準備減倉。 '),color00FFFF,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) THEN
DRAWTEXTABS(12,50,'大盤趨勢不明,注意成交量變化,目前不適宜進場。 '),COLOR00FF00,LINETHICK3;
IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) THEN
DRAWTEXTABS(12,50,'大盤趨勢向下,量能萎縮,不適合進場。 '),COLOR00FF00,LINETHICK3;DRAWTEXTABS(8,25,'所屬板塊:'+BKNAME),ColorFFDE00,linethick3;
流通盤大小:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(66,2,'【流通盤大小:'+NUMTOSTRN(流通盤大小,2)+'億'+'】'),LINETHICK3,COLORRED;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股凈資產:=FINANCE2(4);
銷售毛利率:=FINANCE2(12);
主營收入同比:=FINANCE2(11);
凈利潤同比增長:=FINANCE2(10);
DRAWTEXTABS(160,70,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),COLOR00FF00;
DRAWTEXTABS(160,85,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),COLORRED;
DRAWTEXTABS(160,100,'每股凈資產:'+NUMTOSTRN(每股凈資產,2)+'元'),COLORRED;
DRAWTEXTABS(2,70,'銷售毛利率:'+NUMTOSTRN(銷售毛利率,2)+'%'),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(2,85,'主營收入同比增長:'+NUMTOSTRN(主營收入同比,2)+'%'),LINETHICK1,ColorYELLOW;
DRAWTEXTABS(2,100,'凈利潤同比增長:'+NUMTOSTRN(凈利潤同比增長,2)+'%'),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(3,120,'歷史最高價:'+HHV(HIGH,0)),Colorred,LINETHICK3;
DRAWTEXTABS(3,140,'歷史最低價:'+LLV(LOW,0)),ColorAFFF00,LINETHICK3;SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
DRAWTEXTREL(350,8,'【量能飽和度:'+NUMTOSTRN(SAT,0)+'】'),LINETHICK5,Color8000FF;
AA8:MA(CLOSE,8),color0000FF,LAYER2;
AA13:MA(CLOSE,13),color00ff00,LAYER2;
FILLRGN(MA(C,8),MA(C,13),MA(C,8)>MA(C,13),rgb(150,10,10),MA(C,8)<MA(C,13),rgb(0,100,100)),LAYER4;x1:=(2*C+L+H)/4;
bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;
ema8:=ema(c,8);
DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10),ema8,'∠45上升'),colorwhite;
壓力:WMA(REF(HHV(C,34),1),2),Color0099FF,DOTLINE;
支撐:WMA(REF(LLV(C,34),1),2),ColorABFF46,DOTLINE;
ZX:(壓力+支撐)/2,Color00ffFF,DOTLINE;
PARTLINE(ZX,ZX<=ref(ZX,1),rgb(0,255,0),1,rgb(255,0,0) ),LINETHICK2,LAYER0;
FILLRGN(壓力,ZX,壓力>ZX,RGB(0,0,180)),LAYER7;
FILLRGN(支撐,ZX,支撐<ZX,RGB(50,50,50)),LAYER7;AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(ff1,(LOW* 0.99),'老鼠倉'),Color4080FF;
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑馬線:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趨勢線:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
DRAWTEXT(CROSS(趨勢線,0)AND 黑馬線<40,(HIGH* 0.97),'▲大黑馬'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.992),'【買】'),ALIGN1,Colorff00ff,LINETHICK3;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.008),'【賣】'),ALIGN1,Colorgreen,LINETHICK3;持倉:IF(CLOSE>=SAR(4,2,20),SAR(4,2,20),C),CIRCLEDOT,COLORRED,LINETHICK1;;
空倉:IF(CLOSE<=SAR(4,2,20),SAR(4,2,20),C),CIRCLEDOT,COLORGREEN,LINETHICK1;;{買賣指標}
AA05:=WMA(C,9);
MMA5:=(C-AA05)/AA05*100;
AAA10:WMA(C,13),linethick0;
AA30:WMA(C,34),linethick0;
MM30:=(C-AA30)/AA30*100;
JC:=cross(0,MMA5) and MM30<ref(MM30,1) and AAA10>ref(AAA10,1) ;
減倉:=filter(JC,10);
drawtext(減倉,high*1.065,'◆'),ALIGN2,linethick3,color00ff00;
drawtext(減倉,high*1.055,''),ALIGN1,linethick3,color66ff66;
drawtext(減倉,high*1.055,'☆'),ALIGN1,linethick3,color0099ff;
drawtext(減倉,high*1.064,'◆'),ALIGN0,linethick3,color00ff00;
{高拋低吸}
SJ:=WMA(((2*C+H+L)/4-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100,2);
ZJ:=WMA(0.618*REF(SJ,1)+0.382*SJ,2);
DRAWTEXT(CROSS(SJ,ZJ) AND SJ<30,L,'←吸'),COLOR00FFFF,LINETHICK3,LAYER0;
DRAWTEXT(CROSS(ZJ,SJ) AND SJ>70,H,'←拋'),COLOR00FFFf,LINETHICK3,LAYER0;{---------創歷史新高---------}
X:=BARSLAST(DISPSTATUS=1)+1;
高:=HHvall(HHv(H,X));
跑:=高=H AND ((C-L)<(O-C) OR (O-L)<(C-O));
STICKLINE(跑,C,O,8,0),COLORaaaaaa,LAYER0;;
STICKLINE(跑,C,O,6,0),COLORbbbbbb,LAYER0;;
STICKLINE(跑,C,O,4,0),COLORdddddd,LAYER0;;
STICKLINE(跑,C,O,2,0),COLORFFFFFF,LAYER0;;
DRAWTEXT(跑,H*1.01,'←【高】'),COLORFFFFFF;E:=LLvaLL(LLv(L,X))*0.98;
DIFF:=WMA(CLOSE,12)-WMA(CLOSE,26);
DEA:=WMA(DIFF,9);
MACD:=3*(DIFF-DEA);
SZ:= MACD>REF(MACD,1);
STICKLINE(SZ,E,E+MACD*1.5,1.5,0),COLOR0000CC;
STICKLINE(SZ,E,E+MACD*0.9,2,0),COLOR0000EE;
STICKLINE(SZ,E,E+MACD*0.7,3,0),COLOR0033FF;
STICKLINE(SZ,E,E+MACD*0.5,3,0),COLOR0077FF;
STICKLINE(SZ,E,E+MACD*0.3,3,0),COLOR00BBFF;
STICKLINE(SZ,E,E+MACD*0.1,5,0),COLOR00FFFF;
XD:= MACD<REF(MACD,1);
STICKLINE(XD,E,E+MACD*1.5,1.5,0),COLORCC0033;
STICKLINE(XD,E,E+MACD*0.9,2,0),COLOREE0033;
STICKLINE(XD,E,E+MACD*0.7,3,0),COLORFF3333;
STICKLINE(XD,E,E+MACD*0.5,3,0),COLORFF7733;
STICKLINE(XD,E,E+MACD*0.3,4,0),COLORFFBB33;
STICKLINE(XD,E,E+MACD*0.1,5,0),COLORFFFF33;
CXH:=STRTONUM(STRRIGHT(DATESTR(CURRENTDATE),1));
WARNING('http://www.tzcple.tw',CURRENTTIME>180000 and (CXH=1 OR CXH=6));
DRAWTEXTREL(10 ,10 ,'指標公式');

 

 

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

 

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 511411198  有需要幫忙請點擊這里留言!!!進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票