您現在的位置:程序化交易>> 期貨公式>> 文華財經>> 文華財經公式>>正文內容

均線結合日內第一根K線高低突破跌破模型[文華財經公式]

模型源碼:

 

MA5:=MA(C,5);
MA10:=MA(C,10);
HH:=VALUEWHEN(DATE<>REF(DATE,1),H);
LL:=VALUEWHEN(DATE<>REF(DATE,1),L);
NN:=BARSLAST(DATE<>REF(DATE,1))+1;
HHH:=HHV(H,NN);
LLL:=LLV(L,NN);
MA5>MA10&&TIME>0902&&TIME<1457&&CLOSE>HH,BK;
(TIME>0902&&TIME<1457&&CLOSE<(LLL+HHH)/2)||TIME>=1457,SP;
MA5<MA10&&TIME>0902&&TIME<1457&&CLOSE<LL,SK;
(TIME>0902&&TIME<1457&&CLOSE>(HHH+LLL)/2)||TIME>=1457,BP;

 

 

源碼解析:

MA5賦值:收盤價的5日簡單移動平均
MA10賦值:收盤價的10日簡單移動平均
HH賦值:VALUEWHEN(日期<>昨日日期,最高價)
LL賦值:VALUEWHEN(日期<>昨日日期,最低價)
NN賦值:上次日期<>昨日日期距今天數+1
HHH賦值:NN日內最高價的最高值
LLL賦值:NN日內最低價的最低值
MA5>MA10并且時間>0902并且時間<1457并且收盤價>HH,BK
(時間>0902并且時間<1457并且收盤價<(LLL+HHH)/2)或者時間>=1457,SP
MA5<MA10并且時間>0902并且時間<1457并且收盤價<LL,SK
(時間>0902并且時間<1457并且收盤價>(HHH+LLL)/2)或者時間>=1457,BP
 

 

 

 

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  双色球机选新浪彩票